Mikrotik script giving LA...
Mikrotik script giving LAN IP address
- Home
- Control Panel
- Community Forum
- Services
- Dynamic DNS Service
- Mikrotik script giving LAN IP address
- Community Forum
- Mikrotik script giving LAN IP address
Topic: Mikrotik script giving LAN IP address
There is some thing wrong with the script it giving me router internal ip not wan ip
Reply with quote | Report
/system scriptadd name=Dynupolicy=read,write,testsource=":global ddnsuser mydynusuername:global ddnspass "dynupassword":global theinterface "IN":global ddnshost "myhost.dynu.com":global ipddns [:resolve $ddnshost];:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]:if ([ :typeof $ipfresh ] = nil ) do={:log info ("DynuDDNS: No IP address on $theinterface .")} else={:for i from=( [:len $ipfresh] - 1) to=0 do={:if ( [:pick $ipfresh $i] = "/") do={:set ipfresh [:pick $ipfresh 0 $i];}}:if ($ipddns != $ipfresh) do={:log info ("DynuDDNS: IP-Dynu = $ipddns"):log info ("DynuDDNS: IP-Fresh = $ipfresh"):log info "DynuDDNS: Update IP needed, Sending UPDATE...!":global str "/nic/update?hostname=$ddnshost&myip=$ipfresh"/tool fetch address=api.dynu.com src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/Dynu.".$ddnshost):delay 1:global str [/file find name="Dynu.$ddnshost"];/file remove $str:global ipddns $ipfresh:log info "DynuDDNS: IP updated to $ipfresh!"} else={:log info "DynuDDNS: dont need changes";} }
Reply with quote | Report
Author | Topic: Mikrotik script giving LAN IP address |
---|---|
mohamed saffar Joined: 10/25/2015 |
Mikrotik script giving LAN IP address Thursday, January 14, 2016 12:04 PM
There is some thing wrong with the script it giving me router internal ip not wan ip
|
timothytw Joined: 5/2/2002 |
Mikrotik script giving LAN IP address Friday, January 15, 2016 10:30 AM
Could you please post your script here so that we may take a look?
|
lokka Joined: 10/25/2015 |
Mikrotik script giving LAN IP address Friday, January 15, 2016 10:32 AM
/system scriptadd name=Dynupolicy=read,write,testsource=":global ddnsuser mydynusuername:global ddnspass "dynupassword":global theinterface "IN":global ddnshost "myhost.dynu.com":global ipddns [:resolve $ddnshost];:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]:if ([ :typeof $ipfresh ] = nil ) do={:log info ("DynuDDNS: No IP address on $theinterface .")} else={:for i from=( [:len $ipfresh] - 1) to=0 do={:if ( [:pick $ipfresh $i] = "/") do={:set ipfresh [:pick $ipfresh 0 $i];}}:if ($ipddns != $ipfresh) do={:log info ("DynuDDNS: IP-Dynu = $ipddns"):log info ("DynuDDNS: IP-Fresh = $ipfresh"):log info "DynuDDNS: Update IP needed, Sending UPDATE...!":global str "/nic/update?hostname=$ddnshost&myip=$ipfresh"/tool fetch address=api.dynu.com src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/Dynu.".$ddnshost):delay 1:global str [/file find name="Dynu.$ddnshost"];/file remove $str:global ipddns $ipfresh:log info "DynuDDNS: IP updated to $ipfresh!"} else={:log info "DynuDDNS: dont need changes";} }
|
It is currently Friday, November 15, 2024 7:48 AM US Mountain Standard Time
Friday, November 15, 2024 7:48 AM