mikrotik script
mikrotik script
- Home
- Control Panel
- Community Forum
- Services
- Dynamic DNS Service
- mikrotik script
- Community Forum
- mikrotik script
Topic: mikrotik script
Mikrotik script not work 4 me. Where I am wrong ?:global ddnsuser drdado:global ddnspass mypassword:global theinterface wan:global ddnshost drdado:global ipddns [:resolve $ddnshost];:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]:if ([ :typeof $ipfresh ] = nil ) do={:log info ("dynu: No ip address on $theinterface .")} else={:for i from=( [:len $ipfresh] - 1) to=0 do={:if ( [:pick $ipfresh $i] = "/") do={:set ipfresh [:pick $ipfresh 0 $i];}}:if ($ipddns != $ipfresh) do={:log info ("dynu: IP-dynu = $ipddns"):log info ("dynu: IP-Fresh = $ipfresh"):log info "dynu: Update IP needed, Sending UPDATE...!":global str "/nic/update?hostname=$ddnshost&myip=$ipfresh"/tool fetch address=api.dynu.com src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/Dynu.".$ddnshost):delay 1:global str [/file find name="Dynu.$ddnshost"];/file remove $str:global ipddns $ipfresh:log info "dynu: IP updated to $ipfresh!"} else={:log info "dynu: dont need changes";}}
Reply with quote | Report
:global ddnshost drdadoThe ddnshost is not your username, it should be your hostname/domain name.
Reply with quote | Report
Author | Topic: mikrotik script |
---|---|
drdado Joined: 6/8/2015 |
mikrotik script Wednesday, January 30, 2019 11:39 AM
Mikrotik script not work 4 me. Where I am wrong ?:global ddnsuser drdado:global ddnspass mypassword:global theinterface wan:global ddnshost drdado:global ipddns [:resolve $ddnshost];:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]:if ([ :typeof $ipfresh ] = nil ) do={:log info ("dynu: No ip address on $theinterface .")} else={:for i from=( [:len $ipfresh] - 1) to=0 do={:if ( [:pick $ipfresh $i] = "/") do={:set ipfresh [:pick $ipfresh 0 $i];}}:if ($ipddns != $ipfresh) do={:log info ("dynu: IP-dynu = $ipddns"):log info ("dynu: IP-Fresh = $ipfresh"):log info "dynu: Update IP needed, Sending UPDATE...!":global str "/nic/update?hostname=$ddnshost&myip=$ipfresh"/tool fetch address=api.dynu.com src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/Dynu.".$ddnshost):delay 1:global str [/file find name="Dynu.$ddnshost"];/file remove $str:global ipddns $ipfresh:log info "dynu: IP updated to $ipfresh!"} else={:log info "dynu: dont need changes";}}
|
armo Joined: 6/23/2017 |
mikrotik script Monday, February 11, 2019 8:32 PM
:global ddnshost drdadoThe ddnshost is not your username, it should be your hostname/domain name.
|
It is currently Saturday, November 16, 2024 8:48 AM US Mountain Standard Time
Saturday, November 16, 2024 8:48 AM